読者です 読者をやめる 読者になる 読者になる

いんでぃーづ

個人でゲーム開発してる上で吸収したモノたち紹介。UnityからGIMPまでなんでも。デザインとかゲーム論まで語っちゃうよ的なアレ。

MENU
{スポンサーリンク}

Unity : Android向けビルド時にエラーダイアログが出たらJDKのバージョンかも

Android Tips Unity

Androidビルド時に下のようなダイアログが出たら、

f:id:sugar_affordance:20161102111920p:plain

Unable to convert classes into dex format. See the Console for details.

と出た場合はまずコンソールのエラーログを見ます。

f:id:sugar_affordance:20161102111520p:plain

対象のエラーをタップすると、その下に詳細エラーが出ます。

この欄に

Unsupported major.minor version 52.0

と出ている場合、JDKのバージョンが合っていないことがエラーの原因です。

52.0と出ている場合はJDK8を、51の場合はJDK7を使う必要があります。

Oracleのサイトからダウンロードしましょう。

JDK8のインストール

JDK7のインストール

参考サイト

blog.ch3cooh.jp

Amazon.co.jpアソシエイト